Back to overview
Maintenance
fixed a massive dns and network outage
Aug 25 at 09:12am GMT+8
–
Aug 25 at 09:15am GMT+8
Affected services
sangetavadivelu.com
Resolved
Aug 25 at 09:12am GMT+8
our servers were down following the outage causing the website to be unreachable , we have implemented fixes and the website should be up and running now.
Affected services